CodeWarrior™ Development Studio
for Freescale 68HC12/HCS12/HCS12X/XGATE
Microcontrollers Quick Start

SYSTEM REQUIREMENTS

| Hardware                  | 200 MHz Pentium® II processor or AMD-K6® class processor,
|                          | 128 MB of RAM, and CD-ROM drive
| Operating System         | Microsoft® Windows® 2000/XP
| Disk Space               | Compact: 585 MB
|                          | Full: 735 MB

This Quick Start explains how to install the CodeWarrior Development Studio for HC12 V4.6 software, how to use the IDE to create a project, and how to start debugging a project.

Section A: Installing CodeWarrior Software

1. Install CodeWarrior software
   a. Insert CodeWarrior Development Studio CD into CD-ROM drive — CW Auto Install begins

   **NOTE** If Auto Install does not start, run launch.exe, which is located in the root directory of the CD.

   b. Follow setup program's on-screen instructions

2. Restart your computer — operating system reboots which ensures that CodeWarrior IDE finds newly installed drivers
NOTE  Standard Edition and Professional Edition must be registered. Refer to appendices “Registering and Obtaining License Key for Standard Edition or Professional Edition” or "Manually Installing License Key" to register your software and obtain a permanent license key

Section B: Creating and Building A HC12 Project

1. Launch CodeWarrior IDE
   a. Select Start > Programs > CodeWarrior > CW for HC12 V4.6 — menu appears
   b. Select CodeWarrior IDE — IDE starts, and CodeWarrior window appears

2. From IDE main menu bar, select File > New – New window appears

   New window

3. Create new project

   NOTE  This quick start shows you how to use the New Project Wizard. We use an MC9S12E128 target as an example.

   a. Select HC(S)12 New Project Wizard
   b. In Project name text box, type name you want to give project – IDE automatically adds .mcp extension when it creates project
c. In Location text box enter path to store project or click Set... button to browse to folder.

d. Click OK button — first page of New Project Wizard appears

New Project Wizard - Page 1

![Image of New Project Wizard - Page 1]

- Click Next button — Page 2 of New Project Wizard appears

New Project Wizard - Page 2

![Image of New Project Wizard - Page 2]

- Select MC9S12E128
- Click Next button — Page 3 of New Project Wizard appears
h. Make sure C checkbox is checked
i. Click **Next** button — Page 4 of New Project Wizard appears; allows you to specify whether or not to use Processor Expert

**New Project Wizard - Page 4**

j. Select **No**
k. Click **Next** button — Page 5 of New Project Wizard appears; allows you to specify whether you want project configured to work with PC-lint
I. Select **No**

m. Click **Next** button — Page 6 of New Project Wizard appears; allows you to specify level of startup code

**New Project Wizard - Page 6**

n. Select **ANSI startup code**

o. Click **Next** button — Page 7 of New Project Wizard appears; allows you to specify floating point format that project should be configured to support
p. Select None

q. Click Next button — Page 8 of New Project Wizard appears; allows you to specify memory model that project should be configured to support

r. Select Banked

s. Click Next button — Page 9 of New Project Wizard appears; allows you to specify connections that project should be configured to support
t. Check **Full Chip Simulation** checkbox

u. Click **Finish** button — system creates new project based on information you specified in New Project Wizard; Project window appears, docked at left side of main window

**Project Window**

**NOTE**  To undock Project window, double-click docking handle (double gray lines at top of window). To re-dock window, right click in title bar of Project Window, and select **Docked**.

4. **Select build target**

For this example, we use the build target that connects to the Simulator.
a. Click drop-down menu of Project window
b. Select **Full Chip Simulation** (default)

5. **Edit source code**
   a. Click + sign next to **Sources** folder — tree expands
   b. Double click **main.c** – Editor window opens with **main.c** file

![Image of Editor Window]

   c. Make changes to contents of **main.c** file if desired
   d. If you make changes to **main.c** file, from IDE main menu bar, select **File > Save** – IDE saves changes

6. **Add files if appropriate**
   a. Highlight **Sources** folder
   b. From IDE main menu bar, select **Project** — menu appears
   c. Select **Add Files** — dialog box appears
   d. Navigate to directory that contains file you want to add
   e. Select (highlight) filename of file you want to add to project
   f. Click **Open** button — filename of added file appears under **Sources** folder

7. **Build project**
   a. From IDE main menu bar, select **Project**
   b. Select **Make** — IDE builds (compiles and links) project; Error & Warnings window opens showing error messages and warning messages if detected
Section C: Debugging Your Application

1. Start debugger
   a. From main menu bar, select Project
   b. Select Debug — Debugger Simulator window opens

   Debugger Simulator Window

NOTE   Source and Assembly panes display main.c program and code.

2. Right click mouse on executable line of source code in Source pane to set breakpoints in program code

3. Run application
   a. From Debugger Simulator main menu, select Run — Run menu appears
   b. Select Start/Continue — program executes until encountering the first breakpoint; Command pane displays program status
4. Click Start/Continue icon — Simulator resumes execution
5. Click Halt icon — Simulator stops program execution
6. In Debugger Simulator Window tool bar, select File > Exit to exit Debugger
7. In IDE Main Window tool bar, select File > Exit to exit CodeWarrior IDE

Section D: Creating Project for HCS12X with XGATE Support

1. Launch CodeWarrior IDE
   a. Select Start > Programs > CodeWarrior > CW for HC12 V4.6 — menu appears
   b. Select CodeWarrior IDE — IDE starts
2. From IDE main menu bar, select File > New
   New window
3. Create new project
   a. Select HC(S)12 New Project Wizard
   b. In Project name text box, type name you want to give project – IDE automatically adds .mcp extension when it creates project
   c. In Location text box enter path to store project or click Set... button to browse to folder.
   d. Click OK button — first page of New Project Wizard appears

   New Project Wizard - Page 1

   ![New Project Wizard - Page 1]

   e. Click Next button — Page 2 of New Project Wizard appears

   New Project Wizard - Page 2

   ![New Project Wizard - Page 2]

   f. Select MC9S12XDP512
NOTE  The Project Wizard lists the stationery. We use the MC9S12XDP512 as an example in this quick start.

g. Click **Next** button — Page 3 of New Project Wizard appears

New Project Wizard - Page 3

h. Select **Multi Core (HCS12X and XGATE in RAM)**

i. Click **Next** button — Page 4 of New Project Wizard appears

New Project Wizard - Page 4

j. Make sure **C** checkbox is marked

k. Click **Next** button — Page 5 of New Project Wizard appears; allows you to specify whether you want project configured to work with PC-lint
New Project Wizard - Page 5

1. Select No

m. Click Next button — Page 6 of New Project Wizard appears; allows you to specify HC12 floating point format that project should be configured to support

New Project Wizard - Page 6

n. Select None

o. Click Next button — Page 7 of New Project Wizard appears; allows you to specify XGATE floating point format that project should be configured to support
p. Select None
q. Click Next button — Page 8 of New Project Wizard appears; allows you to specify memory model that project should be configured to support

New Project Wizard - Page 8

r. Select Banked
s. Click Next button — Page 9 of New Project Wizard appears; allows you to specify connections that project should be configured to support
New Project Wizard - Page 9

- Check Full Chip Simulation checkbox
- Click Finish button — Wizard creates new project based on information you specified; Project window appears, docked at left side of main window

Project Window

NOTE To undock Project window, double-click docking handle (double gray lines at top of window). To re-dock window, right click in title bar of Project Window, and select Docked.

4. Select build target

For this example, we use the build target that connects to the Simulator.
5. **Edit source code**
   a. Click + sign next to Sources folder — tree expands
   b. Double click main.c — Editor window opens displaying contents of main.c file

   ![main.c in Editor Window](image)

   c. Make changes to contents of main.c file if desired
   d. If you make changes to main.c file, from IDE main menu bar, select File > Save — IDE saves changes

6. **Add files if appropriate**
   a. Highlight Sources folder
   b. From IDE main menu bar, select Project — menu appears
   c. Select Add Files — dialog box appears
   d. Navigate to directory that contains file you want to add
   e. Select (highlight) filename of file you want to add to project
   f. Click Open button — filename of added file appears under Sources folder
7. Build project
   a. From IDE main menu bar, select **Project**
   b. Select **Make** — IDE builds (compiles and links) project; Error &
      Warnings window opens showing any error and warning
      messages

**Section E: Debugging Your Application**

1. Start debugger
   a. From main menu bar, select **Project**
   b. Select **Debug** — Debugger/Simulator window opens

   ![Debugger/Simulator Window]

**NOTE**  Source and Assembly panes display the `main.c` program and
code. The left set of windows display the state of the HCS12X
core and the right set of windows show state of XGATE core.
2. Right click mouse on executable line of source code in Source pane to set breakpoints in program code

3. Run application
   a. From Debugger/Simulator main menu, select Run – Run menu appears
   b. Select Start/Continue — program executes until encountering the first breakpoint; Command pane displays program status

**NOTE** Alternatively, you can click on Start/Continue icon

---

**Debugger/Simulator Command Pane**

4. Click Start/Continue icon — Simulator resumes program execution

5. Click Halt icon — Simulator stops program execution

6. In Debugger/Simulator Window tool bar, select File > Exit to exit Debugger

7. In IDE Main Window tool bar, select File > Exit to exit CodeWarrior IDE

---

**Congratulations!**

You have successfully created, built, and run an HC12 or HCS12X application with the CodeWarrior for HC12 V4.6 software!
Appendix A: Registering and Obtaining License Key for Standard Edition or Professional Edition

1. Launch CodeWarrior IDE
   a. Select Start > Programs > CodeWarrior > CW for HC12 V4.6 — menu appears
   b. Select CodeWarrior IDE — IDE starts; main window appears

2. Register CodeWarrior software
   a. Select Help > Register Product from the main menu — CodeWarrior IDE starts your browser, taking you to Step 1 of Freescales' on-line registration form
      Register Form Step 1

   b. Select appropriate "start here" that applies

   NOTE  If you downloaded the software from the Freescale web site, you might not have a registration code. You can request a registration code from license@freescale.com. Special Edition customers do not need to register. The Special Edition license file is automatically installed with the software.

   c. Follow on-screen instructions to complete remaining pages of form (Thank You page is last) — within a few minutes Freescale emails your license authorization code


19
3. Obtain license key
   a. From email message you receive from Freescale, copy license
      authorization code
   b. Start CodeWarrior IDE
   c. From CodeWarrior main menu bar, select Help > License
      Authorization — Licence Authorization dialog box appears
   d. Paste license authorization code into License Authorization
      dialog box
   e. Click OK button — License Authorization dialog box updates;
      IDE automatically gets the license key and installs it in the correct
      location

   **NOTE**  The license.dat file with your license key is also emailed to you

   f. From IDE main menu bar, select File > Exit — IDE closes
Appendix B: Manually Installing License Key

NOTE  Following steps explain how to manually install license key. You can find the license.dat file in the directory where you installed CodeWarrior software. The default is: C:\Program Files\Freescale\CW for HC12 V4.6

1. Open license.dat
   a. Start a text editor such as Notepad
   b. Open license.dat file

2. Copy license key you received from Freescale

3. Paste license key on new line at bottom of license.dat file

4. Save license.dat file

5. Close license.dat file – license is installed; IDE uses new license next time you start the CodeWarrior IDE

NOTE  Do not move or delete the license.dat file. If you receive additional keys for other CodeWarrior components, you can add the additional keys to the license.dat file.
Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc. CodeWarrior is a trademark or registered trademark of Freescale Semiconductor, Inc. in the United States and/or other countries. All other product or service names are the property of their respective owners.

Copyright © 2006 by Freescale Semiconductor, Inc. All rights reserved.

Information in this document is provided solely to enable system and software implementers to use Freescale Semiconductor products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits or integrated circuits based on the information in this document.

Freescale Semiconductor reserves the right to make changes without further notice to any products herein. Freescale Semiconductor makes no warranty, representation or guarantee regarding the suitability of its products for any particular purpose, nor does Freescale Semiconductor assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. “Typical” parameters that may be provided in Freescale Semiconductor data sheets and/or specifications can and do vary in different applications and actual performance may vary over time. All operating parameters, including “Typicals”, must be validated for each customer application by customer’s technical experts. Freescale Semiconductor does not convey any license under its patent rights nor the rights of others. Freescale Semiconductor products are not designed, intended, or authorized for use as components in systems intended for surgical implant into the body, or other applications intended to support or sustain life, or for any other application in which the failure of the Freescale Semiconductor product could create a situation where personal injury or death may occur. Should Buyer purchase or use Freescale Semiconductor products for any such unintended or unauthorized application, Buyer shall indemnify and hold Freescale Semiconductor and its officers, employees, subsidiaries, affiliates, and distributors harmless against all claims, costs, damages, and expenses, and reasonable attorney fees arising out of, directly or indirectly, any claim of personal injury or death associated with such unintended or unauthorized use, even if such claim alleges that Freescale Semiconductor was negligent regarding the design or manufacture of the part.

**How to Contact Us**

| Corporate Headquarters | Freescale Semiconductor, Inc.  
|-------------------------|----------------------------------|
| 7700 West Parmer Lane  
| Austin, TX 78729  
| U.S.A. | http://www.freescale.com/codewarrior |
| World Wide Web | http://www.freescale.com/codewarrior |
| Technical Support | http://www.freescale.com/support  
|